Requisitos mínimos para jogar The Last Sorcerer no PC

@empalador

The Last Sorcerer, começou a ser vendido para PC ainda em 2017. The Last Sorcerer chegou a ter uma nota no Metacritic. Então se você está afim de jogar o The Last Sorcerer, é bom dar uma olhadinha no requisitos mínimos e saber se consegue rodar no seu PC.

Requisitos mínimos – The Last Sorcerer

  • Sistema Operacional: 7
  • Processador: Intel i5-4590, AMD FX 8350 equivalent ou superior
  • Memória: 4 GB RAM
  • Placa de Vídeo: Nvidia GeForce GTX 970, AMD Radeon R9 290 equivalent ou superior
  • DirectX: Version 11
  • Internet: No mínimo internet a cabo
  • Espaço em Dísco: 5 GB

Requisitos Recomendados – The Last Sorcerer

  • Sistema Operacional: 10
  • Processador: Intel i5-4590, AMD FX 8350 equivalent ou superior
  • Memória: 6 GB RAM
  • Placa de Vídeo: Nvidia GeForce GTX 970, AMD Radeon R9 290 equivalent ou superior
  • DirectX: Version 11
  • Internet: No mínimo internet a cabo
  • Espaço em Dísco: 5 GB

The Last Sorcerer está disponível para ['PC'].

Like